tcpdump mailing list archives

Re: beta1


From: Guy Harris <guy () alum mit edu>
Date: Thu, 13 Nov 2003 14:52:48 -0800


On Nov 13, 2003, at 1:43 PM, Neil Spring wrote:

1) any chance of removing unused rcsid variables? grep suggests they are always defined but never used. Alternately, move it below the include "interface.h" and edit it to say:
static const char rcsid[] _U_ =

The latter sounds good; that way, you still get the RCS IDs in the image, but you don't get the whinging from the compiler.

2)
print-pppoe.c: In function `pppoe_print':
print-pppoe.c:199: warning: `0' flag ignored with precision and `%X' printf format

I *think* they wanted "%02X" - they print a leading "0x", and then each octet, so they presumably want each octet printed as 2 hex digits.

3) listening on en0, link-type 1 (EN10MB), capture size 96 bytes
seems likely to cause some faqs, if it isn't one already -- I have a 100Mbit link and it says 10MB?

That dates back from when 10 megabits was the *faster* version of Ethernet; "EN10MB" distinguished it from the old experimental 3MB Ethernet, which I think had a different link-layer header (8-bit, rather than 48-bit, addresses).

We could add DLT_ETHERNET as an alias, and use that instead; however, applications probably shouldn't start using DLT_ETHERNET, as, if they did so, they'd only build with versions of libpcap that have it.

Similar problems exist with DLT_IEEE802, which I suspect was introduced because the DLT_ values were originally ARP hardware types, and for some reason there was an ARP type for "IEEE 802 networks" - which doesn't refer to a particular type of network, so it's somewhat meaningless as a DLT_ value, as those values have to specify the link-layer header type. It was subsequently used to mean 802.5 Token Ring.

Perhaps we should change the "dlt_choices[]" table to have two names, one of which is the current name (for compatibility) and one of which is a more descriptive name. "pcap_datalink_val_to_name()" should return the descriptive name; "pcap_datalink_name_to_val()" should accept either of the names.

-
This is the TCPDUMP workers list. It is archived at
http://www.tcpdump.org/lists/workers/index.html
To unsubscribe use mailto:tcpdump-workers-request () tcpdump org?body=unsubscribe


Current thread: