nanog mailing list archives

Re: Switch for SFP+


From: Mauro Gasparini <mjgasparini () gmail com>
Date: Mon, 18 May 2020 15:45:59 -0300

It's clear then that I must use "bridge vlan" to achieve the goal I am looking for.
Now it's time for me to study, research and test on my side.
If I have any specific questions, I will draw on your experience.
Thanks a lot.

El 15/5/20 a las 22:11, Travis Garrison escribió:

On the CRS 3xx line, use vlan filtering instead. This guarantees hardware offloading.

PS. Do not use this method on the 1xx or 2xx lines.

/interface bonding
add mode=802.3ad name=bond-inet slaves=ether9,ether10,ether8 transmit-hash-policy=layer-2-and-3

/interface bridge

add name=bridge vlan-filtering=yes

/interface bridge port

add bridge=bridge interface=bond-inet

add bridge=bridge interface=sfp1

/interface bridge vlan

add bridge=bridge tagged=bond-inet,sfp1 vlan-ids=201

Thanks

Travis

*From:* NANOG <nanog-bounces () nanog org> *On Behalf Of *Mauro Gasparini
*Sent:* Friday, May 15, 2020 10:55 AM
*To:* nanog () nanog org
*Subject:* Re: Switch for SFP+

This works well on my CRSs:

/interface bonding
add mode=802.3ad name=bond-inet slaves=ether9,ether10,ether8 transmit-hash-policy=layer-2-and-3

/interface bridge port
add bridge=br-cabase interface=bond-inet
add bridge=br-cabase interface=sfp1

But if I want to bridge vlans behind some bonding Instead of bridging phy interfaces, cpu explodes:

/interface vlan
add name=vl201-mmen vlan-id=201 interface=sfp1
add name=vl201-mment vlan-id=201 interface=bond-inet

/interface bridge port
add bridge=br-mment interface=vl201-mmen
add bridge=br-mment interface=vl201-mment

El 15/5/20 a las 12:06, Mike Hammett escribió:

    https://wiki.mikrotik.com/wiki/Manual:CRS3xx_series_switches#Bonding



    -----
    Mike Hammett
    Intelligent Computing Solutions <http://www.ics-il.com/>
    
<https://www.facebook.com/ICSIL><https://plus.google.com/+IntelligentComputingSolutionsDeKalb><https://www.linkedin.com/company/intelligent-computing-solutions><https://twitter.com/ICSIL>
    Midwest Internet Exchange <http://www.midwest-ix.com/>
    
<https://www.facebook.com/mdwestix><https://www.linkedin.com/company/midwest-internet-exchange><https://twitter.com/mdwestix>
    The Brothers WISP <http://www.thebrotherswisp.com/>
    <https://www.facebook.com/thebrotherswisp><https://www.youtube.com/channel/UCXSdfxQv7SpoRQYNyLwntZg>

    ------------------------------------------------------------------------

    *From: *"Mauro Gasparini" <mjgasparini () gmail com>
    <mailto:mjgasparini () gmail com>
    *To: *nanog () nanog org <mailto:nanog () nanog org>
    *Sent: *Friday, May 15, 2020 8:55:22 AM
    *Subject: *Re: Switch for SFP+

    Thanks. I am currently using CRS326-24G-2S+ (with routerOS) for
    this, but when I want to do vlan trunking through the bonding, cpu
    load grows from 3% to more than 90%.
    I'm consulting Mikrotik's support in the meantime, because
    routerOS probably doesn't take advantage of the switch hardware as
    swOS would.

    El 15/5/20 a las 10:03, Alain Hebert escribió:

        Hi,

            Mikrotik is a decent product and I'm always amazed at
        their features set, but...

            Using the UI to configuring the switch will punt too much
        traffic toward the CPU.  However, it is possible to configure
        the switch fabric with the cli and attain the desired results.

            It does not compare to a JNP QFX5100 or a Extreme Network
        x650, x670...  etc.

        -----

        Alain Hebert ahebert () pubnix net <mailto:ahebert () pubnix net>

        PubNIX Inc.

        50 boul. St-Charles

        P.O. Box 26770     Beaconsfield, Quebec     H9W 6G7

        Tel: 514-990-5911 http://www.pubnix.net    Fax: 514-990-9443

        On 2020-05-14 15:11, Adam Thompson wrote:

            Have you actually looked at Mikrotik switches?  I don't
            like the OS, but the hardware does what you want it to.

            
https://mikrotik.com/products/group/switches?filter&s=c&r={%22sfp_plus_interface%22:{%22s%22:%223%22,%22e%22:%2224%22}}#!
            
<https://mikrotik.com/products/group/switches?filter&s=c&r=%7b%22sfp_plus_interface%22:%7b%22s%22:%223%22,%22e%22:%2224%22%7d%7d#!>

            If necessary, buy your SFP modules from FS.com and get
            them coded as Mikrotik modules at the factory - that's
            what we do for Cisco, Brocade, Juniper, Extreme, etc.

            Even the top-of-the-line Mikrotik only costs US$899.

            -Adam

            *Adam Thompson*
            Consultant, Infrastructure Services
            [MERLIN LOGO]
            100 - 135 Innovation Drive
            Winnipeg, MB, R3T 6A8
            (204) 977-6824 or 1-800-430-6404 (MB only)
            athompson () merlin mb ca <mailto:athompson () merlin mb ca>
            www.merlin.mb.ca <http://www.merlin.mb.ca/>

            ------------------------------------------------------------------------

            *From:*NANOG <nanog-bounces () nanog org>
            <mailto:nanog-bounces () nanog org> on behalf of Mauro
            Gasparini <mjgasparini () gmail com>
            <mailto:mjgasparini () gmail com>
            *Sent:* Thursday, May 14, 2020 8:46:21 AM
            *To:* Mehmet Akcin
            *Cc:* nanog
            *Subject:* Re: Switch for SFP+

            Thank you. The problem is that to get a price lower than
            U$D 3000 I have to resort to a used device.

            El 14/5/20 a las 01:08, Mehmet Akcin escribió:

                Used Juniper QFX5100-48T will do it. Probably overkill
                but you can grab one cheap @ebay

                On Wed, May 13, 2020 at 16:36 Mauro Gasparini
                <mjgasparini () gmail com <mailto:mjgasparini () gmail com>>
                wrote:

                    Good afternoon.

                    I'm looking for a switch with the following
                    capabilities:
                    . transport for more than 20 gbps
                    . link aggregation LACP
                    . slots for SFP+
                    . seamlessly when trunking vlans through the link
                    aggregation.

                    And essentially that doesn't exceed US$D 2000 and
                    is compatible with
                    10GBASE-ER and/or 10GBASE-ZR modules that are not
                    from the vendor itself
                    (e.g. SPFs: Huawei, Mikrotik, Sumitomo, OEMs).

                    If any of you have a good experience with a device
                    that meets these
                    requirements (which are minimal with the exception
                    of price and
                    compatibility) ?

                    Regards.
                    Mauro Gasparini

--
                Mehmet
                +1-424-298-1903



Current thread: